Live Assist Bot SDK

The Live Assist BOT SDK provides a means for an automated chat endpoint (a bot) to escalate a conversation, such that a visitor can interact with a Live Assist agent.

This SDK is a C# Class library targeting .Net framework 4.6

Once a bot has determined that it wants to put the visitor in touch with an agent, the SDK is employed and a call made to request a chat. A ChatContext object is returned, this is used to reference the chat when performing subsequent operations, such as:

  • Polling for events

  • Posting lines of text to the chat

  • Ending the chat

For the lifetime of the escalated chat, the bot behaves as a relay between the visitor and agent using the SDK.

See Also

Other Resources

Version History


Version History

The topics in this section describe the various changes made to the Live Assist Bot SDK over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 1.0.0

See Also

Other Resources

Live Assist Bot SDK


Version 1.0.0

First release.

See Also

Other Resources

Version History


Cafex.LiveAssist.Bot Namespace

Classes
 | Class | Description
Public class | ChatContext | A references to a chat.
Public class | ChatEvent | An event on a chat, representing either a line of text or a state change.
Public class | ChatException | Thrown in the event of failure to create or operate on a chat. Message for details of the failure.
Public class | ChatInfo | Encapsulates the result of method Poll(ChatContext)
Public class | ChatSpec | An instance of ChatSpec encapsulates properties to start a new chat.
Public class | Sdk | Operations on the Live Assist chat SDK are performed through an instance of this class.
Public class | SdkConfiguration | SdkConfiguration encapsulates SDK configuration parameters.
Public class | TranscriptLine | A line of chat text and associated metadata, used to build a transcript of a chat.
Delegates
 | Delegate | Description
Public delegate | ContextDataDelagate | Return any context data, with with provided context data ID.


ChatContext Class

A references to a chat.
Inheritance Hierarchy
SystemObject
Cafex.LiveAssist.BotChatContext

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
[SerializableAttribute]
public class ChatContext
Remarks
A ChatContext is created and returned by RequestChat(ChatSpec) Subsequent operations on a chat, via Sdk require an instance of ChatContextChatContext is serializable and as such may be persisted to storage; however it should be noted that SDK operations that take a ChatContext as a parameter may update its internal state; in this case, a serialized and stored ChatContext must be updated.
See Also

Reference

Cafex.LiveAssist.Bot Namespace


ChatEvent Class

An event on a chat, representing either a line of text or a state change.
Inheritance Hierarchy
SystemObject
Cafex.LiveAssist.BotChatEvent

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public class ChatEvent

The ChatEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Event ID, unique within the context of a chat.
Public property | Source | The source of the event, either "system", "agent" or "visitor".
Public property | State | If Type is "state", this value is set to one of the following: "waiting", "chatting", "ended"
Public property | Text | If Type is "line", this value is set to the line of text typed
Public property | Time | Time at which the event occured
Public property | Type | Type of event, value is either "state" or "line"
Top
See Also

Reference

Cafex.LiveAssist.Bot Namespace


ChatEvent Properties

The ChatEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Event ID, unique within the context of a chat.
Public property | Source | The source of the event, either "system", "agent" or "visitor".
Public property | State | If Type is "state", this value is set to one of the following: "waiting", "chatting", "ended"
Public property | Text | If Type is "line", this value is set to the line of text typed
Public property | Time | Time at which the event occured
Public property | Type | Type of event, value is either "state" or "line"
Top
See Also

Reference

ChatEvent Class


ChatEvent.Id Property

CafeX Documentation

ChatEventId Property

Event ID, unique within the context of a chat.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string Id { get; }

Property Value

Type: String
See Also

Reference

ChatEvent Class


ChatEvent.Source Property

ChatEventSource Property

The source of the event, either "system", "agent" or "visitor".

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string Source { get; }

Property Value

Type: String
See Also

Reference

ChatEvent Class


ChatEvent.State Property

ChatEventState Property

If Type is "state", this value is set to one of the following: "waiting", "chatting", "ended"

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string State { get; }

Property Value

Type: String
See Also

Reference

ChatEvent Class


ChatEvent.Text Property

ChatEventText Property

If Type is "line", this value is set to the line of text typed

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string Text { get; }

Property Value

Type: String
See Also

Reference

ChatEvent Class


ChatEvent.Time Property

ChatEventTime Property

Time at which the event occured

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string Time { get; }

Property Value

Type: String
See Also

Reference

ChatEvent Class


ChatEvent.Type Property

ChatEventType Property

Type of event, value is either "state" or "line"

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string Type { get; }

Property Value

Type: String
See Also

Reference

ChatEvent Class


ChatException Class

Thrown in the event of failure to create or operate on a chat. Message for details of the failure.
Inheritance Hierarchy
SystemObject
SystemException
Cafex.LiveAssist.BotChatException

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public class ChatException : Exception
See Also

Reference

Cafex.LiveAssist.Bot Namespace


ChatInfo Class

Encapsulates the result of method Poll(ChatContext)
Inheritance Hierarchy
SystemObject
Cafex.LiveAssist.BotChatInfo

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public class ChatInfo

The ChatInfo type exposes the following members.

Properties
 | Name | Description
Public property | AgentName | Agent's name
Public property | AgentTyping | Valid values: "typing", "not-typing"
Public property | ChatEvents | List of events that have occured since last call to Poll(ChatContext)
Public property | ChatTimeout | The time in seconds from the last update time, after which the chat times out and must be updated again before this timeout.
Public property | Duration | Duration of chat
Public property | LastUpdate | The last time that any request was sent to the chat session.
Public property | StartTime | The time the chat started.
Public property | State | Current state, Valid values: "waiting", "chatting", "ended"
Top
See Also

Reference

Cafex.LiveAssist.Bot Namespace


ChatInfo Properties

The ChatInfo type exposes the following members.

Properties
 | Name | Description
Public property | AgentName | Agent's name
Public property | AgentTyping | Valid values: "typing", "not-typing"
Public property | ChatEvents | List of events that have occured since last call to Poll(ChatContext)
Public property | ChatTimeout | The time in seconds from the last update time, after which the chat times out and must be updated again before this timeout.
Public property | Duration | Duration of chat
Public property | LastUpdate | The last time that any request was sent to the chat session.
Public property | StartTime | The time the chat started.
Public property | State | Current state, Valid values: "waiting", "chatting", "ended"
Top
See Also

Reference

ChatInfo Class


ChatInfo.AgentName Property

ChatInfoAgentName Property

Agent's name

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string AgentName { get; }

Property Value

Type: String
See Also

Reference

ChatInfo Class


ChatInfo.AgentTyping Property

ChatInfoAgentTyping Property

Valid values: "typing", "not-typing"

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string AgentTyping { get; }

Property Value

Type: String
See Also

Reference

ChatInfo Class


ChatInfo.ChatEvents Property

ChatInfoChatEvents Property

List of events that have occured since last call to Poll(ChatContext)

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public List<ChatEvent> ChatEvents { get; }

Property Value

Type: ListChatEvent
See Also

Reference

ChatInfo Class


ChatInfo.ChatTimeout Property

ChatInfoChatTimeout Property

The time in seconds from the last update time, after which the chat times out and must be updated again before this timeout.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public long ChatTimeout { get; }

Property Value

Type: Int64
See Also

Reference

ChatInfo Class


ChatInfo.Duration Property

ChatInfoDuration Property

Duration of chat

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public long Duration { get; }

Property Value

Type: Int64
See Also

Reference

ChatInfo Class


ChatInfo.LastUpdate Property

ChatInfoLastUpdate Property

The last time that any request was sent to the chat session.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string LastUpdate { get; }

Property Value

Type: String
See Also

Reference

ChatInfo Class


ChatInfo.StartTime Property

ChatInfoStartTime Property

The time the chat started.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string StartTime { get; }

Property Value

Type: String
See Also

Reference

ChatInfo Class


ChatInfo.State Property

ChatInfoState Property

Current state, Valid values: "waiting", "chatting", "ended"

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string State { get; }

Property Value

Type: String
See Also

Reference

ChatInfo Class


ChatSpec Class

An instance of ChatSpec encapsulates properties to start a new chat.
Inheritance Hierarchy
SystemObject
Cafex.LiveAssist.BotChatSpec

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public class ChatSpec

The ChatSpec type exposes the following members.

Constructors
 | Name | Description
Public method | ChatSpec | Initializes a new instance of the ChatSpec class
Top
Properties
 | Name | Description
Public property | ContextData | If set, the Live Assist SDK will invoke this delagate to retrieve context data. If set, ContextDataHost must also be set.
Public property | Skill | Target an agent with a specific skill. (Optional)
Public property | Transcript | A list of transcript lines that are shown to the agent before the chat starts. Typically these would be used to convey a transcript of a preceding BOT chat. (optional)
Public property | VisitorName | Name of the visitor. (optional)
Top
See Also

Reference

Cafex.LiveAssist.Bot Namespace


ChatSpec Constructor

Initializes a new instance of the ChatSpec class

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public ChatSpec()
See Also

Reference

ChatSpec Class


ChatSpec Properties

The ChatSpec type exposes the following members.

Properties
 | Name | Description
Public property | ContextData | If set, the Live Assist SDK will invoke this delagate to retrieve context data. If set, ContextDataHost must also be set.
Public property | Skill | Target an agent with a specific skill. (Optional)
Public property | Transcript | A list of transcript lines that are shown to the agent before the chat starts. Typically these would be used to convey a transcript of a preceding BOT chat. (optional)
Public property | VisitorName | Name of the visitor. (optional)
Top
See Also

Reference

ChatSpec Class


ChatSpec.ContextData Property

ChatSpecContextData Property

If set, the Live Assist SDK will invoke this delagate to retrieve context data. If set, ContextDataHost must also be set.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public ContextDataDelagate ContextData { get; set; }

Property Value

Type: ContextDataDelagate
See Also

Reference

ChatSpec Class


ChatSpec.Skill Property

ChatSpecSkill Property

Target an agent with a specific skill. (Optional)

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string Skill { get; set; }

Property Value

Type: String
See Also

Reference

ChatSpec Class


ChatSpec.Transcript Property

ChatSpecTranscript Property

A list of transcript lines that are shown to the agent before the chat starts. Typically these would be used to convey a transcript of a preceding BOT chat. (optional)

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public List<TranscriptLine> Transcript { get; set; }

Property Value

Type: ListTranscriptLine
See Also

Reference

ChatSpec Class


ChatSpec.VisitorName Property

ChatSpecVisitorName Property

Name of the visitor. (optional)

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string VisitorName { get; set; }

Property Value

Type: String
See Also

Reference

ChatSpec Class


ContextDataDelagate Delegate

Return any context data, with with provided context data ID.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public delegate string ContextDataDelagate(
    string contextId
)

Parameters

contextId
Type: SystemString
The ContextId, provided by the Live Assist SDK

Return Value

Type: String
See Also

Reference

Cafex.LiveAssist.Bot Namespace


Sdk Class

Operations on the Live Assist chat SDK are performed through an instance of this class.
Inheritance Hierarchy
SystemObject
Cafex.LiveAssist.BotSdk

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public class Sdk

The Sdk type exposes the following members.

Constructors
 | Name | Description
Public method | Sdk | Construct an instance of the SDK with provided configuration.
Top
Methods
 | Name | Description
Public method | EndChat | End a chat.
Public method | GetAvailability | For a given ChatSpec, return true if agents are available for chat. false otherwise.
Public method | Poll | Poll ongoing chat for info and any events occuring since last call to poll, ChatInfo
Public method | PostLine | Post a line of text to the chat
Public method | RequestChat | Request a new chat, routing to an agent based on the criteria specified in the provided ChatSpec. A ChatContext will be returned, this is used to reference the chat when making subsequent calls to the SDK. Live Assist will queue the chat request until a suitable agent is available, if Live Assist does not recognise the criteria specified by the ChatSpec, or a server error occurs, a ChatException will be thrown
Top
See Also

Reference

Cafex.LiveAssist.Bot Namespace


Sdk Constructor

Construct an instance of the SDK with provided configuration.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public Sdk(
    SdkConfiguration sdkConfiguration
)

Parameters

sdkConfiguration
Type: Cafex.LiveAssist.BotSdkConfiguration
Sdk Configuration
See Also

Reference

Sdk Class


Sdk Methods

The Sdk type exposes the following members.

Methods
 | Name | Description
Public method | EndChat | End a chat.
Public method | GetAvailability | For a given ChatSpec, return true if agents are available for chat. false otherwise.
Public method | Poll | Poll ongoing chat for info and any events occuring since last call to poll, ChatInfo
Public method | PostLine | Post a line of text to the chat
Public method | RequestChat | Request a new chat, routing to an agent based on the criteria specified in the provided ChatSpec. A ChatContext will be returned, this is used to reference the chat when making subsequent calls to the SDK. Live Assist will queue the chat request until a suitable agent is available, if Live Assist does not recognise the criteria specified by the ChatSpec, or a server error occurs, a ChatException will be thrown
Top
See Also

Reference

Sdk Class


Sdk.EndChat Method

SdkEndChat Method

End a chat.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public Task<bool> EndChat(
    ChatContext chatContext
)

Parameters

chatContext
Type: Cafex.LiveAssist.BotChatContext
Reference to the chat to end

Return Value

Type: TaskBoolean
True if chat successfully ended
See Also

Reference

Sdk Class


Sdk.GetAvailability Method

SdkGetAvailability Method

For a given ChatSpec, return true if agents are available for chat. false otherwise.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public Task<bool> GetAvailability(
    ChatSpec chatSpec
)

Parameters

chatSpec
Type: Cafex.LiveAssist.BotChatSpec
Reference to the chat to end

Return Value

Type: TaskBoolean
true if agents are available for chat. false otherwise
See Also

Reference

Sdk Class


Sdk.Poll Method

SdkPoll Method

Poll ongoing chat for info and any events occuring since last call to poll, ChatInfo

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public Task<ChatInfo> Poll(
    ChatContext chatContext
)

Parameters

chatContext
Type: Cafex.LiveAssist.BotChatContext
Reference to specific chat to poll

Return Value

Type: TaskChatInfo
An instance of ChatInfo
See Also

Reference

Sdk Class


Sdk.PostLine Method

SdkPostLine Method

Post a line of text to the chat

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public Task<bool> PostLine(
    string text,
    ChatContext chatContext
)

Parameters

text
Type: SystemString
The line of text to post
chatContext
Type: Cafex.LiveAssist.BotChatContext
Reference to the specific chat

Return Value

Type: TaskBoolean
True if line successfully posted
See Also

Reference

Sdk Class


Sdk.RequestChat Method

SdkRequestChat Method

Request a new chat, routing to an agent based on the criteria specified in the provided ChatSpec. A ChatContext will be returned, this is used to reference the chat when making subsequent calls to the SDK. Live Assist will queue the chat request until a suitable agent is available, if Live Assist does not recognise the criteria specified by the ChatSpec, or a server error occurs, a ChatException will be thrown

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public Task<ChatContext> RequestChat(
    ChatSpec chatSpec
)

Parameters

chatSpec
Type: Cafex.LiveAssist.BotChatSpec
Routing criteria and chat configuration

Return Value

Type: TaskChatContext
A ChatContext referencing the requested chat
See Also

Reference

Sdk Class


SdkConfiguration Class

SdkConfiguration encapsulates SDK configuration parameters.
Inheritance Hierarchy
SystemObject
Cafex.LiveAssist.BotSdkConfiguration

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public class SdkConfiguration

The SdkConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | SdkConfiguration | Initializes a new instance of the SdkConfiguration class
Top
Properties
 | Name | Description
Public property | AccountNumber | The Live Assist account number
Public property | ContextDataHost | Host name of the Context Data service. May be unset if Context Data service is not required.
Public property | ContextDataPort | Port of the Context Data Service.
Top
See Also

Reference

Cafex.LiveAssist.Bot Namespace


SdkConfiguration Constructor

Initializes a new instance of the SdkConfiguration class

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public SdkConfiguration()
See Also

Reference

SdkConfiguration Class


SdkConfiguration Properties

The SdkConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AccountNumber | The Live Assist account number
Public property | ContextDataHost | Host name of the Context Data service. May be unset if Context Data service is not required.
Public property | ContextDataPort | Port of the Context Data Service.
Top
See Also

Reference

SdkConfiguration Class


SdkConfiguration.AccountNumber Property

SdkConfigurationAccountNumber Property

The Live Assist account number

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string AccountNumber { get; set; }

Property Value

Type: String
Remarks
This is a mandatory parameter.
See Also

Reference

SdkConfiguration Class


SdkConfiguration.ContextDataHost Property

SdkConfigurationContextDataHost Property

Host name of the Context Data service. May be unset if Context Data service is not required.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string ContextDataHost { get; set; }

Property Value

Type: String
See Also

Reference

SdkConfiguration Class


SdkConfiguration.ContextDataPort Property

SdkConfigurationContextDataPort Property

Port of the Context Data Service.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public int ContextDataPort { get; set; }

Property Value

Type: Int32
See Also

Reference

SdkConfiguration Class


TranscriptLine Class

A line of chat text and associated metadata, used to build a transcript of a chat.
Inheritance Hierarchy
SystemObject
Cafex.LiveAssist.BotTranscriptLine

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
[SerializableAttribute]
public class TranscriptLine

The TranscriptLine type exposes the following members.

Constructors
 | Name | Description
Public method | TranscriptLine | Initializes a new instance of the TranscriptLine class
Top
Properties
 | Name | Description
Public property | IsBot | True if this line was written by a bot.
Public property | Line | Line of text written.
Public property | SrcName | Name of the author of the line.
Public property | Timestamp | DateTime at which the line occured.
Top
See Also

Reference

Cafex.LiveAssist.Bot Namespace


TranscriptLine Constructor

Initializes a new instance of the TranscriptLine class

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public TranscriptLine()
See Also

Reference

TranscriptLine Class


TranscriptLine Properties

The TranscriptLine type exposes the following members.

Properties
 | Name | Description
Public property | IsBot | True if this line was written by a bot.
Public property | Line | Line of text written.
Public property | SrcName | Name of the author of the line.
Public property | Timestamp | DateTime at which the line occured.
Top
See Also

Reference

TranscriptLine Class


TranscriptLine.IsBot Property

TranscriptLineIsBot Property

True if this line was written by a bot.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public bool IsBot { get; set; }

Property Value

Type: Boolean
See Also

Reference

TranscriptLine Class


TranscriptLine.Line Property

TranscriptLineLine Property

Line of text written.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string Line { get; set; }

Property Value

Type: String
See Also

Reference

TranscriptLine Class


TranscriptLine.SrcName Property

TranscriptLineSrcName Property

Name of the author of the line.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public string SrcName { get; set; }

Property Value

Type: String
See Also

Reference

TranscriptLine Class


TranscriptLine.Timestamp Property

TranscriptLineTimestamp Property

DateTime at which the line occured.

Namespace: Cafex.LiveAssist.Bot
Assembly: LiveAssistBotSDK (in LiveAssistBotSDK.dll) Version: 1.0.0.1 (1.0.0.1)
Syntax
C#
Copy
public DateTime Timestamp { get; set; }

Property Value

Type: DateTime
See Also

Reference

TranscriptLine Class